Jump to content


Lbckf

Member Since 30 Jul 2009
Offline Last Active Oct 28 2012 02:06 AM

Topics I've Started

Can't run the game

07 October 2012 - 01:53 AM

Game maker prompted me with a new update. I chose to update. This is the first one that actually installed successfully without me having to end the process in Task Manager. So I tried to run my game to see if I would have to change any code, and this came up:
Posted ImageI sent the email to YoYoGames and tried again. Same thing. Is this my fault?
Error : gml_Object_obj_control_Step_0(342) : Unsure where these come from
Error : Exception : System.InvalidOperationException: Stack empty.
   at System.Collections.Generic.Stack`1.Pop()
   at GMAssetCompiler.GML2VM.CompileAssign(GMLToken _tok)
   at GMAssetCompiler.GML2VM.CompileBlock(GMLToken _tok)
   at GMAssetCompiler.GML2VM.CompileIf(GMLToken _tok)
   at GMAssetCompiler.GML2VM.CompileBlock(GMLToken _tok)
   at GMAssetCompiler.GML2VM.CompileIf(GMLToken _tok)
   at GMAssetCompiler.GML2VM.CompileBlock(GMLToken _tok)
   at GMAssetCompiler.GML2VM.CompileBlock(GMLToken _tok)
   at GMAssetCompiler.GML2VM.Compile(GMAssets _assets, GMLCode _code)
   at GMAssetCompiler.IFFSaver.Save(GMAssets _assets, String _name)
   at GMAssetCompiler.Program.Main(String[] _args)

[Workaround found!]Shift and Control not working

15 September 2012 - 03:05 AM

After the new update, Game Maker Studio isn't responding to control and shift anymore. I am using a game that had it working perfectly. Setting it to a different key works fine, but I need it shift. Any help?

Workaround:
In create:
shift=0
In step:
shift=(shift&1)*2+keyboard_check_direct(vk_lshift)
When shift=1 it's pressed. When shift=2 it's released. When shift=3 it's held down.

Is there a get_directory alternative?

11 September 2012 - 08:17 PM

In GM:S, get_drectory and get_directory_alt are obsolete. Is there anything else I can use to select a folder?

[SOLVED]pause.png

17 August 2012 - 05:47 PM

Trying to make a pause function, half works.
So I have all objects disable when I press ESC except pause object. But before that it takes a screenshot and saves it to working_directory+"pause.png", then draws that saved png to 0,0. That works perfectly using sprite_add.
Press ESC again,
instance_activate_all()
with(PauseObj)instance_destroy() //The object drawing the background image, the pause.png
sprite_delete(drawPause) //The pause.png, saved using a variable
if file_exists(working_directory+"pause.png") {
file_delete(working_directory+"pause.png")
} //Delete pause.png so we can make a new one for the next pause
Everything works, except file_delete. It just WON'T go away, until I go to working_directory in Windows Explorer and delete it myself. How can I get rid of it?

The next time I press ESC, it displays the old pause.png from last time I paused.

My Mac is a security breach?

14 August 2012 - 04:11 AM

I am trying to compile my game to run on Mac. I got all my settings running fine, when I check Mac connection it says the connection failed. In the compile box at the bottom, I get this exact copy and paste:
WARNING - POTENTIAL SECURITY BREACH!
The server's host key does not match the one PuTTY has
cached in the registry. This means that either the
server administrator has changed the host key, or you
have actually connected to another computer pretending
to be the server.
The new rsa2 key fingerprint is:
ssh-rsa 2048 ba:a3:6e:51:06:e2:c0:05:75:f2:ab:b0:04:e7:5f:4a
Connection abandoned.
So I tried to clear the SSH keys, and I get this:
'"C:\Users\Lbckf\AppData\Roaming\GameMaker-Studio\putty\putty"' is not recognized as an internal or external command,
operable program or batch file.
It seems I'm missing something called putty (isn't that the ssh thing? Like filezilla?) but it somehow kept tabs on a server host key. I went to appdata, gm studio, putty and there is no putty application (like it said), and there is seemingly nothing that recorded a "server host key". There are, however, 3 sh files which all seem to be harmless in the task I am trying to do. There is a bat file called yyyy. I didn't run it, but I did see what was inside:
y
y
y
y
y
y
y
There is also a plink.exe and a pscp.exe. So what can I do here?