Jump to content


How to compile Android APK

  • Please log in to reply
4 replies to this topic

#1 McFish


    GMC Member

  • New Member
  • 15 posts
  • Version:GM:Studio

Posted 16 June 2015 - 07:40 AM

Here's how I managed to get Gamemaker (1.4.1567) to compile android APK on Windows 8.1 PRO 64-bit. Hopefully this helps, as I had to spend almost 2 days fighting my way out of this damn changing labyrint:


  • Download and install latest 32-bit Java JDK. Currently: 7u79 (jdk-7u79-windows-i586.exe)
  • Download and install Android SDK 24.0.2 (DO NOT use latest version)
  • SDK should install to folder: c:\users\username\AppData\Local\Android\android-sdk
  • Go to the folder and open "SDK Manager". Click "Obsolete"-checkbox to see older api versions
  • Install the following:

    Under Tools:
      DO NOT update android SDK tools
      Android SDK Platform-tools
      Android SDK Build-tools

    From API-15, API-13 and API-8 folders:
      SDK Platform and Google APIs

    From API-15:
      Intel x86 atom image
      ARM system image

    From extras:
      Android support library
      Google play services
      Google play APK extension
      Google play billing
      Google play Licensing
      Google USB driver
  • Download 32-bit android NDK r10d

    Note: r10e is the latest, but it doesn't work, so use older version
  • File is self extracting 7zip package, so move it to for example documents folder and run it. It should create folder: android-ndk-r10d
  • Open gamemaker and open File/Preferences . Then navigate to android tab and set SDK locations:
    Android SDK location:  c:\users\user\appdata\local\android\android-sdk
    Android NDK location: c:\users\user\documents\android-ndk-r10d
    Java JDK: c:\program files (x86)\java\jdk1.7.0_79\
  • Press: Check android sdk and check android ndk


Note: If you want to install android studio on the same computer, install 64-bit version of java jdk alongside 32-bit jdk and use 64-bit studio. Also make sure, that android studio installs SDK to different location than c:\users\username\AppData\Local\Android\android-sdk

Edited by McFish, 16 June 2015 - 10:01 AM.

  • 0


#2 mead182


    GMC Member

  • New Member
  • 5 posts
  • Version:GM:Studio

Posted 16 June 2015 - 08:35 AM

Oh my god thank you!

  • 0



    GMC Member

  • New Member
  • 2 posts
  • Version:GM:Studio

Posted 16 June 2015 - 09:55 PM

Hello everyone, I'm new to this great community , sorry for my English is not very good, you are being a great help , I have the same problem and took 5 days without continuing my game . thanks friends.

  • 0

#4 RobertK


    GMC Member

  • GMC Member
  • 18 posts
  • Version:GM:Studio

Posted 18 June 2015 - 04:01 PM



just done the same ... had to go back to NDK 10b to get a YYC compile to work though.


Also worth noting ... I do quite a bit of work on a laptop which is quick but currently has an SSD of limited size. Trying to get rid of another bug (see next post) I hit update everything in the SDK with my brain in neutral at 2am. 1 cup of coffee later 40G download appeared completely filling my HD.


Regards, Rob.

  • 0

#5 ABG


    GMC Member

  • GMC Member
  • 9 posts
  • Version:GM:Studio

Posted 05 March 2016 - 10:56 AM

This was very helpful. Thank you McFish.

One thing: for version (v.1.4.1598) is needed also  API-16 with SDK Platform and Google APIs 

  • 0