Jump to content


Photo

Gm:Studio Not Launching Correctly


  • Please log in to reply
19 replies to this topic

#1 kevb34ns

kevb34ns

    GMC Member

  • New Member
  • 7 posts
  • Version:GM:Studio

Posted 30 November 2013 - 07:06 AM

Hey all,

 

I'm not sure if this is the right forum for this topic, but it seems to be the most active and I am very limited on time. I'm using GM:S Standard Edition on a MBP(Win7 through Boot Camp). Yesterday I hibernated the computer, and when I opened it again Windows gave me a warning about potential memory issues. When I tried to open GameMaker:

  • it immediately jumped to a <new game> window, rather than showing the usual window asking which project to open.
  • It then gives me a warning dialog "Out of memory."
  • in the window, there's text at the top that says "Registered To:School Name"
  • clicking on Help->Update License says that the program is unregistered, even though I am registered.
  • Edit: Clicking on the run game button brings up a dialog that says "Item Not Found."
  • I have tried uninstalling, reinstalling, restarting the computer, etc.

Does anyone know why this is happening? I'm desperate.


Edited by kevb34ns, 30 November 2013 - 07:59 AM.

  • 0

#2 Nocturne

Nocturne

    Nocturne Games

  • Administrators
  • 25708 posts
  • Version:GM:Studio

Posted 30 November 2013 - 07:27 AM

I believe that this was a known bug with the previous version of GMS (v1.2.1220)... I suggest that you uninstall the program, reboot, then re-install the latest version (v1.2.1224) from their website as that should resolve the issue.


  • 0

U1FVsm3.png

40799.png


#3 kevb34ns

kevb34ns

    GMC Member

  • New Member
  • 7 posts
  • Version:GM:Studio

Posted 30 November 2013 - 07:58 AM

Hey Nocturne,

 

When I reinstalled it, it seems to have updated, because it states that it's running v1.2.1224. 


  • 0

#4 Nocturne

Nocturne

    Nocturne Games

  • Administrators
  • 25708 posts
  • Version:GM:Studio

Posted 30 November 2013 - 08:03 AM

Hmmm... okay, do the following:

 

1) unistall GMS.

2) use regedit and remove the GMS registry settings "Computer\HKEY_CURRENT_USER\Software\GMStudio\Version 1.0\Preferences"

3) reboot and install again.

 

if that doesn't solve the issue, then I'm afraid you'll have to contact the help desk and request some help from them as I doubt it's something that we on the forums can resolve for you.


  • 0

U1FVsm3.png

40799.png


#5 kevb34ns

kevb34ns

    GMC Member

  • New Member
  • 7 posts
  • Version:GM:Studio

Posted 30 November 2013 - 08:20 AM

Alright well, just for the record I guess, I followed your steps and it didn't work, then deleted all GM data from the registry, and it still didn't work. 


  • 0

#6 shirsakbc

shirsakbc

    GMC Member

  • GMC Member
  • 52 posts
  • Version:GM8

Posted 30 November 2013 - 03:44 PM

I once had the "Item Not Found" error when mistakenly moved GMS to another location. Try checking if all the files are at the correct location. (That would be "%Appdata%\Gamemaker-Studio".)


  • 0

Zzzzzz...Zzzzzz...


#7 bobsyo0978

bobsyo0978

    GMC Member

  • New Member
  • 1 posts
  • Version:GM:Studio

Posted 04 December 2013 - 02:14 PM

I can only say i got exactly same problem, and shirsakbc I am sure I didn't moved the files to another location. I have tried deleting all GMS files and that include the files in %Appdata%.  :)

 

Another thing is when i try close GMS i get an error saying "I/O error 32."  :sweat:


Edited by bobsyo0978, 04 December 2013 - 02:19 PM.

  • 0

#8 Rtyp06

Rtyp06

    GMC Member

  • GMC Member
  • 1858 posts
  • Version:GM:Studio

Posted 04 December 2013 - 07:27 PM

The last couple of days I've had to re-enter my product key twice. I had purposefully redownloaded and installed v1.2.1220 prior because of unacceptable issues when 1.2.1224 was initially released. It still says I'm using 1.2.1220 but I get a big upgrade to game maker studio standard splash screen whenever I start up GM:S now. It's no longer forcing me to produce the product key (today at least) but having to re-input the product key is annoying.


  • 1

#9 LooseSeal

LooseSeal

    GMC Member

  • New Member
  • 12 posts
  • Version:GM:Studio

Posted 13 December 2013 - 04:55 AM

I had your exact same problem earlier today. Doing a Google search led to me this post. It has been over a week, so hopefully the problem is fixed for you. What finally fixed everything for me was a combination of the suggestions posted here. 

Uninstall

Delete the remaining folder "D:\Steam Game Installations\SteamApps\common\gamemaker_studio" (I install my Steam apps to a custom location)

Delete the registry key "\HKEY_CURRENT_USER\Software\GMStudio\Version 1.0\Preferences"

Delete the AppData folder "C:\Users\username\AppData\Local\gamemaker_studio"

Restart

Reinstall

 

After doing this I was able to launch GM with it working perfectly. I did lose all of my settings and preferences though. 

 

P.S. 

I'm using the Steam version of GM in case you didn't notice. 


  • 2

#10 Zeckros

Zeckros

    GMC Member

  • New Member
  • 3 posts
  • Version:GM:Studio

Posted 16 December 2013 - 11:25 PM

I had your exact same problem earlier today. Doing a Google search led to me this post. It has been over a week, so hopefully the problem is fixed for you. What finally fixed everything for me was a combination of the suggestions posted here. 

Uninstall

Delete the remaining folder "D:\Steam Game Installations\SteamApps\common\gamemaker_studio" (I install my Steam apps to a custom location)

Delete the registry key "\HKEY_CURRENT_USER\Software\GMStudio\Version 1.0\Preferences"

Delete the AppData folder "C:\Users\username\AppData\Local\gamemaker_studio"

Restart

Reinstall

 

After doing this I was able to launch GM with it working perfectly. I did lose all of my settings and preferences though. 

 

P.S. 

I'm using the Steam version of GM in case you didn't notice. 

 

This worked for me!  Thank you, LooseSeal, you are a life saver!

 

Also I can confirm that this works with the non-Steam version as well.


  • 0

#11 Asmaa Hassan

Asmaa Hassan

    GMC Member

  • New Member
  • 1 posts
  • Version:GM:Studio

Posted 05 January 2014 - 02:56 PM

I had your exact same problem earlier today. Doing a Google search led to me this post. It has been over a week, so hopefully the problem is fixed for you. What finally fixed everything for me was a combination of the suggestions posted here. 

Uninstall

Delete the remaining folder "D:\Steam Game Installations\SteamApps\common\gamemaker_studio" (I install my Steam apps to a custom location)

Delete the registry key "\HKEY_CURRENT_USER\Software\GMStudio\Version 1.0\Preferences"

Delete the AppData folder "C:\Users\username\AppData\Local\gamemaker_studio"

Restart

Reinstall

 

After doing this I was able to launch GM with it working perfectly. I did lose all of my settings and preferences though. 

 

P.S. 

I'm using the Steam version of GM in case you didn't notice. 

 

i am new to GMS and i have faced this problem .. sorry but i don' understand what is the steam and appdata folder and registry key .. and where i could find them ??
 


  • 0

#12 teslatronik

teslatronik

    GMC Member

  • GMC Member
  • 171 posts
  • Version:GM:Studio

Posted 22 March 2014 - 06:25 PM

i have tried all of the above with no luck, does anyone have any more suggestions ?

 

i get the error File Access Denied (i am Admin on the machine) then i can click O.K and it brings me into GM with Registered to School Name...it also says i am running version master collection 0.0.0

 

 

edit--------

 

Updating to the Beta Version 1.3.1307 fixed this for me. (using the GMStudio-Installer-1.3.1307 )


Edited by teslatronik, 23 March 2014 - 05:31 AM.

  • 0

#13 AJAY777

AJAY777

    GMC Member

  • GMC Member
  • 79 posts
  • Version:GM:Studio

Posted 13 June 2014 - 04:35 PM

I had your exact same problem earlier today. Doing a Google search led to me this post. It has been over a week, so hopefully the problem is fixed for you. What finally fixed everything for me was a combination of the suggestions posted here. 

Uninstall

Delete the remaining folder "D:\Steam Game Installations\SteamApps\common\gamemaker_studio" (I install my Steam apps to a custom location)

Delete the registry key "\HKEY_CURRENT_USER\Software\GMStudio\Version 1.0\Preferences"

Delete the AppData folder "C:\Users\username\AppData\Local\gamemaker_studio"

Restart

Reinstall

 

After doing this I was able to launch GM with it working perfectly. I did lose all of my settings and preferences though. 

 

P.S. 

I'm using the Steam version of GM in case you didn't notice. 

Wow :sorcerer:  :sorcerer:  :sorcerer:  Working!!! You save my life. Really solve my Big Problem....  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:


  • 0

#14 Evilbecky

Evilbecky

    GMC Member

  • GMC Member
  • 218 posts
  • Version:GM:Studio

Posted 27 August 2014 - 12:01 AM

How do I fix it if I don't have the steam version of GameMaker-Studio?


  • 0

#15 fodormik

fodormik

    GMC Member

  • New Member
  • 3 posts
  • Version:GM:HTML5

Posted 13 September 2014 - 10:13 AM

 

I had your exact same problem earlier today. Doing a Google search led to me this post. It has been over a week, so hopefully the problem is fixed for you. What finally fixed everything for me was a combination of the suggestions posted here. 

Uninstall

Delete the remaining folder "D:\Steam Game Installations\SteamApps\common\gamemaker_studio" (I install my Steam apps to a custom location)

Delete the registry key "\HKEY_CURRENT_USER\Software\GMStudio\Version 1.0\Preferences"

Delete the AppData folder "C:\Users\username\AppData\Local\gamemaker_studio"

Restart

Reinstall

 

After doing this I was able to launch GM with it working perfectly. I did lose all of my settings and preferences though. 

 

P.S. 

I'm using the Steam version of GM in case you didn't notice. 

Wow :sorcerer:  :sorcerer:  :sorcerer:  Working!!! You save my life. Really solve my Big Problem....  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:  :thanks:

 

Same problem! Thanks for the solution, but I found an even shorter way based on LooseSeal's suggestion:

 

just rename the C:\Users\username\AppData\Local\gamemaker_studio folder

and you are as at a clean install. Restart the GM Studio and enter your license keys and you are done.


  • 0

#16 Kidando

Kidando

    GMC Member

  • New Member
  • 16 posts
  • Version:GM:Studio

Posted 19 September 2014 - 08:25 PM

 

Same problem! Thanks for the solution, but I found an even shorter way based on LooseSeal's suggestion:

 

just rename the C:\Users\username\AppData\Local\gamemaker_studio folder

and you are as at a clean install. Restart the GM Studio and enter your license keys and you are done.

This worked for me as well. Thank you so much


  • 0

gmc_signature_for_kidando_net_by_kidando

 

WEBSITE: kidando.net | TWITTER: @kidando | FACEBOOK PAGE: Kidando


#17 K_Man_ALPHA

K_Man_ALPHA

    GMC Member

  • New Member
  • 6 posts
  • Version:GM:Studio

Posted 29 October 2014 - 03:58 PM

Lucille you LooseSeal - that same process just worked for me!

My PC had been having some memory issues and I think GM got hit somehow - causing a "no memory" issue at every launch.

 

THanks!


  • 0

My YouTube Gaming Channel: https://www.youtube....SQINzm6_Fxxi1Qw


#18 BeboeLasvagas

BeboeLasvagas

    GMC Member

  • GMC Member
  • 21 posts
  • Version:GM:Studio

Posted 19 November 2014 - 02:23 AM

this is what worked!!! after searching all day... Please don't keep this error, it happened to me a month ago fixed it's self and returned. I am going to have to learn some other game dev stuff in the mean time, because if it's going to happen again just the way game maker is set up.

 

EXHALE.... At least it's working for today, after 8 hours of looking. Thank you


Edited by BeboeLasvagas, 19 November 2014 - 02:23 AM.

  • 0

banner.png


#19 franking64

franking64

    GMC Member

  • GMC Member
  • 47 posts
  • Version:GM:Studio

Posted 14 December 2014 - 09:17 PM

I had the same problem. I uninstalled, did the regedit as Norcturne said, reinstalled and everything returned back in order.


  • 0

#20 RobertRamsay

RobertRamsay

    GMC Member

  • New Member
  • 9 posts
  • Version:GM:Studio

Posted 06 February 2015 - 01:03 PM

Using version 1.4.1474 and suddenly had all of the above symptoms when launching gamemaker, even though it had been fine 2 days ago when using it.

 

None of the above worked for me.

 

Out of memory error

Registered to : School Name

 

At least I got rid of the I/O error on exit, but I also have nothing in my module drop-down list. 

 

Any help would be great


Edited by RobertRamsay, 06 February 2015 - 01:09 PM.

  • 0