Jump to content


Photo

Weird GM Studio error.........


  • This topic is locked This topic is locked
45 replies to this topic

#31 P5y

P5y

    GMC Member

  • GMC Member
  • 183 posts

Posted 25 November 2012 - 09:40 PM

its fixed
  • 0

#32 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 26 November 2012 - 12:17 AM

Ok so everything seems to be working again and my game isn't getting messed with anymore. I'm glad that it was fixed, but this problem put me back a day or so on releasing my game -_-' and hopefully it won't come back.
  • 1

#33 VMblast

VMblast

    GMC Member

  • GMC Member
  • 6 posts
  • Version:GM:Studio

Posted 26 November 2012 - 12:41 AM

Hello,
I have downloaded a free version to try out few days ago, and now I got these skulls all over my sprites. I have managed to fix it after few hours, but now this gets me thinking if this kind of thing is going to pop out often, then I don't see the point in buying a pro version that I already decided to buy.
I had to re-import entire graphics all over again, and luckily this was just a small tryout before I start to do anything more serious( buy pro-version), so not much of graphics.
Then it got me thinking what if I had tons of graphics, I really have second thoughts now. This error is a huge time waste.
  • 0

#34 Racroz

Racroz

    GMC Member

  • GMC Member
  • 16 posts
  • Version:Unknown

Posted 26 November 2012 - 02:15 AM

The same thing happens to me, actually, i came right now to find or make a thread about it, i tried updating to 1.1.676 but no luck :l i get those damn skulls that keep giving me work.
Where do we ask for a fix?

EDIT: i tried the fix posted here and i worked wonders, no more skull pirates :] i'm a game maker, not a pirate. Thanks alot to mike.dailly.

Edited by Racroz, 26 November 2012 - 03:20 AM.

  • 0

#35 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 26 November 2012 - 03:05 AM

Hello,
I have downloaded a free version to try out few days ago, and now I got these skulls all over my sprites. I have managed to fix it after few hours, but now this gets me thinking if this kind of thing is going to pop out often, then I don't see the point in buying a pro version that I already decided to buy.
I had to re-import entire graphics all over again, and luckily this was just a small tryout before I start to do anything more serious( buy pro-version), so not much of graphics.
Then it got me thinking what if I had tons of graphics, I really have second thoughts now. This error is a huge time waste.

I think you should still buy Studio, even though this error wasted a whole day of development for me and my team, I am not going to give up using it. As long as the staff knows what has been happening to a lot of people recently since the last update and fix it I will continue to use it and buy more exports. But if I where you, I would continue to use the Free version until this is fixed.
  • 0

#36 slayer 64

slayer 64

    Slayer of gingers

  • GMC Member
  • 3856 posts
  • Version:GM8.1

Posted 26 November 2012 - 03:08 AM

i wonder if loading the resources externally would go around the problem. eeh. i like gm8.1
  • 1

#37 Andy

Andy

    GMC Veteran

  • GMC Member
  • 1876 posts
  • Version:GM:Studio

Posted 26 November 2012 - 03:49 AM

There should not be anything, programmed into GM: Studio, which can potentially erase all of a user’s sprites. DRM, especially this kind, hurts ligament consumers.

I assume after reading more that GM does not pertinently delete and replace your sprites?

Edited by Andy, 26 November 2012 - 03:55 AM.

  • 1

#38 NakedPaulToast

NakedPaulToast

    GM Studio/Mac/Win

  • GMC Member
  • 8218 posts
  • Version:GM:Studio

Posted 26 November 2012 - 04:03 AM

There should not be anything, programmed into GM: Studio, which can potentially erase all of a userís sprites. DRM, especially this kind, hurts ligament consumers.

I assume after reading more that GM does not pertinently delete and replace your sprites?

I'm not so sure.

I'm guessing if you inadvertantly hit OK from the sprite editor and save your project the skulls will get saved.

It certainly appears that GM's anti-piracy code is registering a false positive and then vandalizing people's projects. As much as I've been an advocate for GM and YYGs, this is just wrong.
  • 4

#39 Loaf

Loaf

    Just loafing around

  • GMC Member
  • 1578 posts
  • Version:GM:Studio

Posted 26 November 2012 - 04:29 AM

Its becoming clear this isn't an issue related to piracy or viruses. I tweeted about this and GM user I know also is experiencing the problem. This seems to be getting more widespread.

It certainly appears that GM's anti-piracy code is registering a false positive and then vandalizing people's projects. As much as I've been an advocate for GM and YYGs, this is just wrong.


Totally agree.

This is a colossal ****up.
  • 0

#40 Big J

Big J

    GMC Member

  • GMC Member
  • 2848 posts
  • Version:GM8.1

Posted 26 November 2012 - 04:58 AM

DRM is, and always will be, a huge failure. It fails to do the one thing it was designed to do, that is stopping piracy. In addition, it just causes unnecessary trouble for the legitimate users, which is easy to see here.

Even if a program does implement DRM proper, it doesn't sabotage or vandalize projects like Game Maker: Studio does, especially for the ones who are not pirating the software. This is just really bad. I don't even know where to start.

Edited by Big J, 26 November 2012 - 04:58 AM.

  • 0

#41 TerraFriedSheep

TerraFriedSheep

    GMC Member

  • GMC Member
  • 3138 posts
  • Version:GM:Studio

Posted 26 November 2012 - 08:05 AM

If anything, this topic should prompt those that don't already to create some backups of their work.
  • 0

#42 greyzebra

greyzebra

    GMC Member

  • GMC Member
  • 116 posts
  • Version:GM:Studio

Posted 26 November 2012 - 09:01 AM

Just updated to 1.1.676 following Mike's instruction, and so far no problem...
  • 0

#43 P5y

P5y

    GMC Member

  • GMC Member
  • 183 posts

Posted 26 November 2012 - 11:28 AM

I wonder if gamemaker would let me use those skull sprites in my game
  • 0

#44 Sulsay

Sulsay

    GMC Member

  • GMC Member
  • 256 posts
  • Version:GM:Studio

Posted 26 November 2012 - 04:46 PM

Has this error been fixed in the current version?

In other words, can I safely open my project when I get home in an hour or two?
  • 0

#45 GameGeisha

GameGeisha

    GameGeisha

  • GMC Member
  • 4272 posts
  • Version:GM:Studio

Posted 26 November 2012 - 05:02 PM

When I first updated to 1.1.676 from 1.1.666, 5pice froze before I even had to chance to see any skulls. It forced me to do a full reinstall, and as of today it is still working properly (knock on wood). This is probably caused by a faulty delta that changed the GUI to something that still ran for some of you but appeared to be tampered with.

GameGeisha
  • 0

#46 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 3250 posts
  • Version:GM:Studio

Posted 26 November 2012 - 05:02 PM

Focused here: http://gmc.yoyogames...dpost&p=4150203
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users