Jump to content


Photo

Weird GM Studio error.........


  • This topic is locked This topic is locked
45 replies to this topic

#1 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 24 November 2012 - 05:32 PM

Hey everyone, I have been working on this TDS Game for a while now and I am about ready to release a Pre-Alpha version, but when I opened the project today I was surprised to see skulls on almost all my sprites! I'll show a picture below to show you guys what I mean.

Posted Image

Can someone please help me with this!?!
  • 1

Logo.png


#2 Samuel Venable

Samuel Venable

    GMC Member

  • Banned Users
  • 632 posts
  • Version:GM:Studio

Posted 24 November 2012 - 05:35 PM

Do you have a pirated version of GMS? - That might explain the pirate skulls :P
Spoiler

#3 gtagamer

gtagamer

    GMC Member

  • GMC Member
  • 72 posts
  • Version:GM:Studio

Posted 24 November 2012 - 05:57 PM

this is not an error
you are using pirated version of game maker studio
  • -1

aewk9j.png

<iframe width='320' height='480' frameBorder='0' src='http://geometricmobile.clay.io?embed&embedtype=128'></iframe>

PLACE IT ON YOUR WEBSITE


#4 Futhark

Futhark

  • GMC Member
  • 891 posts
  • Version:GM8.1

Posted 24 November 2012 - 06:03 PM

The mods ought to have ye walk ye olde plank. Yarr! :P

Posted Image
  • 0

My GMC Board Display Settings:
I can NOT see your sig, pics or avatars.
Let me know if I miss anything important you're trying to show me.

Information Overbloat Error in Function:Eye


#5 Samuel Venable

Samuel Venable

    GMC Member

  • Banned Users
  • 632 posts
  • Version:GM:Studio

Posted 24 November 2012 - 06:04 PM

This is funny haha..

I saw a site that was hosting stolen copies of GM studio and was ready to report it to YYG but looks like they already have it under control. :D
Spoiler

#6 Futhark

Futhark

  • GMC Member
  • 891 posts
  • Version:GM8.1

Posted 24 November 2012 - 06:11 PM

...Can someone please help me with this!?!


Here's the solution to your problem :thumbsup:
  • -6

My GMC Board Display Settings:
I can NOT see your sig, pics or avatars.
Let me know if I miss anything important you're trying to show me.

Information Overbloat Error in Function:Eye


#7 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 4737 posts
  • Version:GM:Studio

Posted 24 November 2012 - 06:14 PM

Please don't ASSUME folk are using pirated copies, sometimes a virus or something can effect an exe and gives some issue like this.

The current solution is to uninstall, delete both %appdata%\GameMaker-Studio and %localappdata%\GameMaker-Studio, delete the GameMaker-Studio registry key, scan your machine in case its a virus, and then reinstall.

The program assumes a modded .exe is a crack, but this isn't always the case as a virus can also change it. I also have a feeling theres something else changing exe's.....

If your still having issues, get in touch with the help desk, let them know your key...and we'll see what we can do to help.
  • 7

#8 Futhark

Futhark

  • GMC Member
  • 891 posts
  • Version:GM8.1

Posted 24 November 2012 - 06:16 PM

Please don't ASSUME folk are using pirated copies, sometimes a virus or something can effect an exe and gives some issue like this...


Ok, wise words indeed. Apologies to the original poster. Hope it gets fixed.
  • 5

My GMC Board Display Settings:
I can NOT see your sig, pics or avatars.
Let me know if I miss anything important you're trying to show me.

Information Overbloat Error in Function:Eye


#9 Samuel Venable

Samuel Venable

    GMC Member

  • Banned Users
  • 632 posts
  • Version:GM:Studio

Posted 24 November 2012 - 06:18 PM

With that being said, mike, I have a site to report. I'll send it to you in a PM...

Edit: double sorry to the OP :(

Edited by time-killer-games, 24 November 2012 - 06:19 PM.

Spoiler

#10 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 24 November 2012 - 06:52 PM

Thank you Mike, I will uninstall it and download again when I get on my computer. And no problem everyone, I do not have a cracked version of GameMaker Studio and this error only happened on this game not any of my others.
  • 1

Logo.png


#11 Alpha Beta Soup

Alpha Beta Soup

    GMC Member

  • GMC Member
  • 178 posts
  • Version:GM:Studio

Posted 24 November 2012 - 07:04 PM

That happened to me last night too. Closing studio then starting it again fixed it though.

EDIT: Yay! my first +1 rep Posted Image

Edited by Alpha Beta Soup, 24 November 2012 - 09:21 PM.

  • 5

#12 Arusiasotto

Arusiasotto

    GMC Member

  • GMC Member
  • 760 posts
  • Version:GM:Studio

Posted 24 November 2012 - 09:17 PM

Yeah, it's been reported several times this latest patch. I am assuming it might actually be a bug where the anti-piracy measures are being a tad zealous. Someone also reported a skull issue after crashing GMX by loading really large assets.
  • 0

 

"It should be noted that no ethically-trained software engineer would ever consent to write a DestroyBaghdad procedure. Basic professional ethics would instead require him to write a DestroyCity procedure, to which Baghdad could be given as a parameter." - Nathaniel Borenstein

 

 

 


#13 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 24 November 2012 - 09:27 PM

Well I find it weird that it only happened to this project, luckily for me I do backup my projects a lot so I will not have to do much work on it. I am going to also re-install it just to be sure
  • 0

Logo.png


#14 Alpha Beta Soup

Alpha Beta Soup

    GMC Member

  • GMC Member
  • 178 posts
  • Version:GM:Studio

Posted 24 November 2012 - 09:32 PM

Does it affect your save files or is it just placed over the sprites in the program? I wasn't sure so I didn't save after they showed up and closed it.
  • 0

#15 kburkhart84

kburkhart84

    Firehammer Games

  • GMC Member
  • 1981 posts
  • Version:GM:Studio

Posted 25 November 2012 - 04:10 AM

I'm getting the same problem. It is a very small project, and it isn't a cracked version. I hadn't seen it before until today, both before and after the latest update. I had 1.1.676, and I upgraded to 1.1.677, and both versions are doing it. My solution for the moment is to simply reload the sprites, which lasts until GM does it again. I only have two sprites so it isn't much hassle, at least until Yoyo fixes it.
  • 0

My KBInput system is now on the marketplace here.  It wraps up nice and tight GMStudio's input system into a few function calls making a user configurable input system that works the same regardless of what inputs the player has chosen including keyboard, mouse buttons, and gamepad/joysticks using DInput/XInput.  The support forum topic for it is here.


#16 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 25 November 2012 - 06:59 AM

Ok well as an update to everyone, I uninstalled GM:Studio and deleted the registry files, then re-installed it but that only worked until I fixed all my sprites, after that I ran the game and bam they had more pirates then ever (about 5 per sprite). And I also realized that this only started happening after this past update, did they do something that would cause this or what because this is a major deal and I need this problem fixed for the game to stay on track.
  • 0

Logo.png


#17 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 4737 posts
  • Version:GM:Studio

Posted 25 November 2012 - 10:15 AM

Did you delete everything (local app data, and app data, AND registry key)?
  • 0

#18 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 25 November 2012 - 10:46 AM

Did you delete everything (local app data, and app data, AND registry key)?

I deleted the Registry but not the Local AppData, so I will try that right now! I'm hoping that it works!!!
  • 0

Logo.png


#19 DamnICantFly

DamnICantFly

    GMC Member

  • GMC Member
  • 16 posts
  • Version:Unknown

Posted 25 November 2012 - 11:14 AM

I got the exact same thing! Random skull keep on popping up on my sprites! I also have an orriginal version from Game Maker Studio.
I also got it after the last update.. -.-
I wish I never updated it.. It's freaking me out!
I made a video from it: https://www.youtube....h?v=hrEHAyBGsW4
  • 0

#20 dczemina

dczemina

    GMC Member

  • New Member
  • 2 posts
  • Version:GM:Studio

Posted 25 November 2012 - 03:28 PM

I am getting the same issue and it has only been happening since the latest update.
  • 0

#21 Alpha Beta Soup

Alpha Beta Soup

    GMC Member

  • GMC Member
  • 178 posts
  • Version:GM:Studio

Posted 25 November 2012 - 03:47 PM

The current solution is to uninstall, delete both %appdata%\GameMaker-Studio and %localappdata%\GameMaker-Studio, delete the GameMaker-Studio registry key, scan your machine in case its a virus, and then reinstall.


I have done this and it worked for a short while but now its happening again. I am using v1.1.666. Any other suggestions to fix this?
  • 0

#22 kburkhart84

kburkhart84

    Firehammer Games

  • GMC Member
  • 1981 posts
  • Version:GM:Studio

Posted 25 November 2012 - 06:23 PM

I uninstalled and deleted my appdata folders. Upon reinstalling version 1.1.167 it so far is working fine. I believe that the issue is that somehow the updater itself is corrupting the executable, or the size of executable that the anti-piracy code is looking is set wrong. My computer is clean, so I doubt it would happen due to any virii, and the same as others, it started happening with version 1.1.166, though updating to 1.1.167 did not fix the problem until I reinstalled.
  • 1

My KBInput system is now on the marketplace here.  It wraps up nice and tight GMStudio's input system into a few function calls making a user configurable input system that works the same regardless of what inputs the player has chosen including keyboard, mouse buttons, and gamepad/joysticks using DInput/XInput.  The support forum topic for it is here.


#23 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 4737 posts
  • Version:GM:Studio

Posted 25 November 2012 - 06:37 PM

@ AlphaBetaSoup: WHich version are you having trouble with? The one from our site, or Steam? What license + modules do you have?
  • 0

#24 Alpha Beta Soup

Alpha Beta Soup

    GMC Member

  • GMC Member
  • 178 posts
  • Version:GM:Studio

Posted 25 November 2012 - 06:42 PM

@ AlphaBetaSoup: WHich version are you having trouble with? The one from our site, or Steam? What license + modules do you have?

The one on your site, Pro, no modules
  • 0

#25 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 4737 posts
  • Version:GM:Studio

Posted 25 November 2012 - 06:45 PM

Can you PM me the email you used to register, since you did the delete reinstall thing, I want to verify that your license is actually functional and something else isn't kicking in.

The new "Delta Updater" messing things up, is a possibility, and something we'll look at.
  • 0

#26 P5y

P5y

    GMC Member

  • GMC Member
  • 196 posts

Posted 25 November 2012 - 08:19 PM

:( i just got professional + HTML off steam

I got skulls on mine , but now the application keeps on closing by itself

what the heck is going on!!! Is yoyo games going to fix this ?

Im not going to reinstall because I dont really want to mess around with steam folders.

im running 1.1.676

Edited by P5y, 25 November 2012 - 08:20 PM.

  • 0

#27 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 25 November 2012 - 08:52 PM

Ok I think my problem is fixed, although it has only been a couple hours so I am going to be weary. But I am going to go ahead and say that it is most likely the latest update that had messed everything up. Hopefully the YoYo Games team can fix this in the next couple of days so that I can start working on my game again (I have not even tried working on my main project over the fear of it just adding more of those pirates).
  • 0

Logo.png


#28 TKidder

TKidder

    GMC Member

  • Banned Users
  • 10 posts
  • Version:GM:Studio

Posted 25 November 2012 - 08:55 PM

This also happened to me I completely restored my pc and it has not happened since

#29 Alpha Beta Soup

Alpha Beta Soup

    GMC Member

  • GMC Member
  • 178 posts
  • Version:GM:Studio

Posted 25 November 2012 - 09:12 PM

Seems you have to re-install using 1.1.676 like kburkhart84 and Mike.Dailly said. It seems to be working fine now for me. I was using an older installer before.
  • 0

#30 P5y

P5y

    GMC Member

  • GMC Member
  • 196 posts

Posted 25 November 2012 - 09:35 PM

ive reinstalled and also deleted the registry. Ill see if its fixed
  • 0

#31 P5y

P5y

    GMC Member

  • GMC Member
  • 196 posts

Posted 25 November 2012 - 09:40 PM

its fixed
  • 0

#32 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 26 November 2012 - 12:17 AM

Ok so everything seems to be working again and my game isn't getting messed with anymore. I'm glad that it was fixed, but this problem put me back a day or so on releasing my game -_-' and hopefully it won't come back.
  • 1

Logo.png


#33 VMblast

VMblast

    GMC Member

  • GMC Member
  • 6 posts
  • Version:GM:Studio

Posted 26 November 2012 - 12:41 AM

Hello,
I have downloaded a free version to try out few days ago, and now I got these skulls all over my sprites. I have managed to fix it after few hours, but now this gets me thinking if this kind of thing is going to pop out often, then I don't see the point in buying a pro version that I already decided to buy.
I had to re-import entire graphics all over again, and luckily this was just a small tryout before I start to do anything more serious( buy pro-version), so not much of graphics.
Then it got me thinking what if I had tons of graphics, I really have second thoughts now. This error is a huge time waste.
  • 0

#34 Racroz

Racroz

    GMC Member

  • GMC Member
  • 16 posts
  • Version:Unknown

Posted 26 November 2012 - 02:15 AM

The same thing happens to me, actually, i came right now to find or make a thread about it, i tried updating to 1.1.676 but no luck :l i get those damn skulls that keep giving me work.
Where do we ask for a fix?

EDIT: i tried the fix posted here and i worked wonders, no more skull pirates :] i'm a game maker, not a pirate. Thanks alot to mike.dailly.

Edited by Racroz, 26 November 2012 - 03:20 AM.

  • 0

#35 Techcore Studios

Techcore Studios

    GMC Member

  • GMC Member
  • 37 posts
  • Version:GM:Studio

Posted 26 November 2012 - 03:05 AM

Hello,
I have downloaded a free version to try out few days ago, and now I got these skulls all over my sprites. I have managed to fix it after few hours, but now this gets me thinking if this kind of thing is going to pop out often, then I don't see the point in buying a pro version that I already decided to buy.
I had to re-import entire graphics all over again, and luckily this was just a small tryout before I start to do anything more serious( buy pro-version), so not much of graphics.
Then it got me thinking what if I had tons of graphics, I really have second thoughts now. This error is a huge time waste.

I think you should still buy Studio, even though this error wasted a whole day of development for me and my team, I am not going to give up using it. As long as the staff knows what has been happening to a lot of people recently since the last update and fix it I will continue to use it and buy more exports. But if I where you, I would continue to use the Free version until this is fixed.
  • 0

Logo.png


#36 slayer 64

slayer 64

    Slayer of gingers

  • GMC Member
  • 4244 posts
  • Version:GM:Studio

Posted 26 November 2012 - 03:08 AM

i wonder if loading the resources externally would go around the problem. eeh. i like gm8.1
  • 1

5y5rs3d.pngfg0UQNL.png


#37 Andy

Andy

    GMC Veteran

  • GMC Member
  • 1935 posts
  • Version:GM:Studio

Posted 26 November 2012 - 03:49 AM

There should not be anything, programmed into GM: Studio, which can potentially erase all of a user’s sprites. DRM, especially this kind, hurts ligament consumers.

I assume after reading more that GM does not pertinently delete and replace your sprites?

Edited by Andy, 26 November 2012 - 03:55 AM.

  • 1
Please visit Andygames.com today!

#38 NakedPaulToast

NakedPaulToast

    GM Studio/Mac/Win

  • GMC Member
  • 8588 posts
  • Version:GM:Studio

Posted 26 November 2012 - 04:03 AM

There should not be anything, programmed into GM: Studio, which can potentially erase all of a userís sprites. DRM, especially this kind, hurts ligament consumers.

I assume after reading more that GM does not pertinently delete and replace your sprites?

I'm not so sure.

I'm guessing if you inadvertantly hit OK from the sprite editor and save your project the skulls will get saved.

It certainly appears that GM's anti-piracy code is registering a false positive and then vandalizing people's projects. As much as I've been an advocate for GM and YYGs, this is just wrong.
  • 4

keep_crap_150_zpsd7af69c5.png


#39 Loaf

Loaf

    Just loafing around

  • GMC:Member
  • 1878 posts
  • Version:GM:Studio

Posted 26 November 2012 - 04:29 AM

Its becoming clear this isn't an issue related to piracy or viruses. I tweeted about this and GM user I know also is experiencing the problem. This seems to be getting more widespread.

It certainly appears that GM's anti-piracy code is registering a false positive and then vandalizing people's projects. As much as I've been an advocate for GM and YYGs, this is just wrong.


Totally agree.

This is a colossal ****up.

:duck:


#40 Big J

Big J

    GMC Member

  • GMC Member
  • 2852 posts
  • Version:GM8.1

Posted 26 November 2012 - 04:58 AM

DRM is, and always will be, a huge failure. It fails to do the one thing it was designed to do, that is stopping piracy. In addition, it just causes unnecessary trouble for the legitimate users, which is easy to see here.

Even if a program does implement DRM proper, it doesn't sabotage or vandalize projects like Game Maker: Studio does, especially for the ones who are not pirating the software. This is just really bad. I don't even know where to start.

Edited by Big J, 26 November 2012 - 04:58 AM.

  • 0

Read this before contacting me with a mentor request. This text file is subject to amendments at any time, without notice.

 

Get your GM 8.1 Anti-Aliasing here!
2712265.png


#41 TerraFriedSheep

TerraFriedSheep

    GMC Member

  • GMC Member
  • 3238 posts
  • Version:GM:Studio

Posted 26 November 2012 - 08:05 AM

If anything, this topic should prompt those that don't already to create some backups of their work.
  • 0

#42 greyzebra

greyzebra

    GMC Member

  • GMC Member
  • 119 posts
  • Version:GM:Studio

Posted 26 November 2012 - 09:01 AM

Just updated to 1.1.676 following Mike's instruction, and so far no problem...
  • 0

#43 P5y

P5y

    GMC Member

  • GMC Member
  • 196 posts

Posted 26 November 2012 - 11:28 AM

I wonder if gamemaker would let me use those skull sprites in my game
  • 0

#44 Sulsay

Sulsay

    GMC Member

  • GMC Member
  • 256 posts
  • Version:GM:Studio

Posted 26 November 2012 - 04:46 PM

Has this error been fixed in the current version?

In other words, can I safely open my project when I get home in an hour or two?
  • 0

#45 GameGeisha

GameGeisha

    GameGeisha

  • GMC Member
  • 5275 posts
  • Version:GM:Studio

Posted 26 November 2012 - 05:02 PM

When I first updated to 1.1.676 from 1.1.666, 5pice froze before I even had to chance to see any skulls. It forced me to do a full reinstall, and as of today it is still working properly (knock on wood). This is probably caused by a faulty delta that changed the GUI to something that still ran for some of you but appeared to be tampered with.

GameGeisha
  • 0

Latest Releases:

Due to a recent project failure, I will be taking a leave until the end of July for further self-study. If you have questions regarding content in my posts, please contact me through email.


#46 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 4737 posts
  • Version:GM:Studio

Posted 26 November 2012 - 05:02 PM

Focused here: http://gmc.yoyogames...dpost&p=4150203
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users