Jump to content


Photo

Game Maker: Studio crashes after about 1 minute


  • This topic is locked This topic is locked
17 replies to this topic

#1 darktree

darktree

    GMC Member

  • GMC Member
  • 31 posts
  • Version:GM8

Posted 07 November 2012 - 03:17 PM

Hello, I have Game Maker Studio Pro in Steam for Windows 7.

After having my project open for about 30 seconds and try to run it, game maker will crash/self close in the background while the game is running. The game itself never crashes and plays fine.
I even went back a few versions of my game and it still crashes now even with old projects. I've even tried opening other peoples projects that previously ran fine on my machine.
My game does not use sounds or anything that could be considered obnoxious.
I tested the integrity of the data cache with Steams checker thing, everything check out.
I have restarted the computer.
My version is 1.1.615.

Everything seems to work fine until I run a preview of my game, after which it runs the preview fine, but GM crashes in the background.

What is going on?

Edited by darktree, 07 November 2012 - 03:23 PM.

  • 0

#2 Mr. RPG

Mr. RPG

    GMC's Forum Troll

  • GMC Member
  • 3056 posts
  • Version:GM:Studio

Posted 07 November 2012 - 03:29 PM

While I doubt it will fix the problems you have, make sure you update to the newest version (1.1.622 I think it is)
  • 0

#3 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 3024 posts
  • Version:GM:Studio

Posted 07 November 2012 - 03:48 PM

You're copy has become corrupted, uninstall it, and reinstall it. I'd also scan for viruses just in case.
  • 0

#4 MarcusM

MarcusM

    GMC Member

  • GMC Member
  • 27 posts

Posted 12 November 2012 - 10:35 AM

You're copy has become corrupted, uninstall it, and reinstall it. I'd also scan for viruses just in case.


I have the same problem. I've deleted the local Steam install and reinstalled. I continue to have the game crash after running my game.
  • 0

#5 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 3024 posts
  • Version:GM:Studio

Posted 12 November 2012 - 11:35 AM

You might have a virus, or a scanner which is modifying the program. Try deleting everything (including localstorage stuff), nuking registry - everything. if it's still doing it, something is modding the .exe
  • 0

#6 MarcusM

MarcusM

    GMC Member

  • GMC Member
  • 27 posts

Posted 12 November 2012 - 05:58 PM

You might have a virus, or a scanner which is modifying the program. Try deleting everything (including localstorage stuff), nuking registry - everything. if it's still doing it, something is modding the .exe


This problem doesn't occur when I run the non Steam version of the Gamemaker Studio. Is this still a problem with virus protection?
  • 0

#7 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 3024 posts
  • Version:GM:Studio

Posted 12 November 2012 - 06:47 PM

They aren't identical .exe's, the Steam one has more stuff in it to handle workshop and Steams API - so who knows.

Which version are you using on Steam? What modules?
  • 0

#8 MarcusM

MarcusM

    GMC Member

  • GMC Member
  • 27 posts

Posted 12 November 2012 - 07:49 PM

They aren't identical .exe's, the Steam one has more stuff in it to handle workshop and Steams API - so who knows.

Which version are you using on Steam? What modules?



I have the plain vanilla version of Studio. Standard, I believe, v1.1.622. So, the modules I have are Mac OS X, Windows, Steam Workshop, And Windows8(Javascript). This is what the "About Gamemaker" says when I select it.

Weird. I just reboot my machine and tried running again. I'm not having the issue. I wonder if there was just something weird going on. I'll respond if I see the issue again.
  • 0

#9 Sn0wBlizz4rd

Sn0wBlizz4rd

    GMC Member

  • GMC Member
  • 5 posts
  • Version:GM:Studio

Posted 24 November 2012 - 07:29 AM

Same problem -.-
  • 0

#10 Pallas

Pallas

    GMC Member

  • GMC Member
  • 94 posts

Posted 24 November 2012 - 03:02 PM

After having my project open for about 30 seconds and try to run it, game maker will crash/self close in the background while the game is running. The game itself never crashes and plays fine.
I even went back a few versions of my game and it still crashes now even with old projects. I've even tried opening other peoples projects that previously ran fine on my machine.
My game does not use sounds or anything that could be considered obnoxious.
I tested the integrity of the data cache with Steams checker thing, everything check out.
I have restarted the computer.
My version is 1.1.615.

Same problem here, with GameMaker Studio Professional, but Version 1.1.676 (latest?). Problems started today (last time without problems was monday), has been working fine for about a month. Restarting Steam, restarting computer and even reinstalling via Steam didn't work. After some research I found out that the crash only occurs when I'm running my game. Just like Sn0wBlizz4rd said, GameMaker then crashes but the game keeps running fine. It doesn't matter whether I'm running on Android or Windows.
  • 0

#11 SecondReality

SecondReality

    GMC Member

  • GMC Member
  • 311 posts
  • Version:GM:Studio

Posted 24 November 2012 - 07:37 PM

Same with me!
I have the newest update of GMS since today and now when I test my game, GMS crashes in the background!
Hopefully they'll fix this soon!
  • 0

#12 thegame

thegame

    Flying Penguin

  • GMC Member
  • 1481 posts
  • Version:GM:Studio

Posted 25 November 2012 - 04:34 AM

If we put more posts on this, will they fix it sooner? Anyway, I have the same problem... I tried rebooting, reinstalling, and even going to another computer, downloading steam, and installing it there. It still crashes after running, on both computers.
  • 0

#13 Kodras

Kodras

    GMC Member

  • New Member
  • 2 posts
  • Version:GM:Studio

Posted 25 November 2012 - 11:24 AM

Registered to post about this, found it already exists here, so might as well join in the posting

Having the exact same issue- 8.1 has run fine for ages, bought Studio on Steam on offer (with the HTML5 bit) and it's crashing 30 seconds or so after compiling, whether the game is left open or not. Have verified cache integrity on steam, fully reinstalled three times, wiped out all my temporary files etc, tried disabling all my antivirus/spyware/malware programs (and all other non-essential processes) and even running in compatibility mode- Nothing's worked :(

Oh also forgot to mention, it happens regardless of the content of the project- I've tried with both the game i'm working on, a random example project i found on here somewhere and with a just plain empty project with an empty room- still crashes

Edited by Kodras, 25 November 2012 - 11:26 AM.

  • 0

#14 Spacedog

Spacedog

    GMC Member

  • GMC Member
  • 14 posts

Posted 25 November 2012 - 12:27 PM

Same for me. Even the tutorials crashed GM:S, but only on my Netbook. My PC was OK, but didn't test for too long. Tried re-installing Game Maker and Steam and no joy. Bought a new Netbook out of frustration and it works on that.

Edited by Spacedog, 25 November 2012 - 01:02 PM.

  • 0

#15 Spacedog

Spacedog

    GMC Member

  • GMC Member
  • 14 posts

Posted 25 November 2012 - 12:41 PM

I don't know if this is a related issue but might be worth a mention. When I go to install GM:S Pro in Steam it is not listed under software I own in my library, but when I search for it in the store it says I own it and lets me install. Could be related?
  • 0

#16 ral9005

ral9005

    GMC Member

  • New Member
  • 16 posts
  • Version:Unknown

Posted 25 November 2012 - 12:59 PM

Registered to post about this, found it already exists here, so might as well join in the posting

Having the exact same issue- 8.1 has run fine for ages, bought Studio on Steam on offer (with the HTML5 bit) and it's crashing 30 seconds or so after compiling, whether the game is left open or not. Have verified cache integrity on steam, fully reinstalled three times, wiped out all my temporary files etc, tried disabling all my antivirus/spyware/malware programs (and all other non-essential processes) and even running in compatibility mode- Nothing's worked :(

Oh also forgot to mention, it happens regardless of the content of the project- I've tried with both the game i'm working on, a random example project i found on here somewhere and with a just plain empty project with an empty room- still crashes



It cant be a virus or something. It happend now the second time to me... U have to uninstall the Gamemaker and then delete the entries in the localappdata folder and in the registry (start-regedit and then search for the key and delete it, for example: \HK_CURRENT_USER\Software\GMStudio_Steam).

Then you can reinstall it and it will work fine untill u open a project-file that changes something and then you have the same problem: you run a game and Gamemaker crashes... I dont know which project-file exactly causes this error/changes but it happend to me when I opened a demo-file from steam and another tutorial/education-file from the forum of this side... no clue...
  • 0

#17 emxibus

emxibus

    GMC Member

  • GMC Member
  • 48 posts
  • Version:GM:Studio

Posted 26 November 2012 - 02:56 PM

Though I'd add myself to the list of peopel with this problem.

I have

GM S: Steam with

iOS
HTML5

OS: Windows 7

Edited by emxibus, 26 November 2012 - 02:56 PM.

  • 0

#18 Mike.Dailly

Mike.Dailly

    Evil YoYo Games Employee

  • Administrators
  • 3024 posts
  • Version:GM:Studio

Posted 26 November 2012 - 05:02 PM

Focused here: http://gmc.yoyogames...dpost&p=4150203
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users