Jump to content


Photo

Does your GM:S update fail?


  • Please log in to reply
80 replies to this topic

#1 Chronic

Chronic

    Administrator

  • Global Moderators
  • 2729 posts
  • Version:GM:Studio

Posted 26 July 2012 - 07:59 PM

I've been having an issue with updating GameMaker:Studio recently and i've slowly found what i think is the cause of the problem, but need some help to confirm it. The problem lies with the virus scanner i use called Kaspersky.

From what i understand the update process goes something like this.

- GM updater checks for a new version and downloads a file to /GameMaker-Studio/UpgradeZIP/
- The file is extracted to GameMaker-Studio/Upgrade
- the /UpgradeZip/ is then deleted
- The contents of of /Upgrade/ are then moved to /GameMaker-Studio/

Its during this last step that update fails, as Kaspersky is seemingly preventing the updater from moving files, causing the updater to stop responding (seems to get stuck in a loop). I've also noticed that during this last part the updater records progress to Trace.log, including errors. Which because its stuck in a loop, it will rapidly write errors to the log until the updater process is terminated (making the trace.log file size grow quickly).

Once the updater has been terminated, GameMaker:Studio will then fail to open again. If you watch the task manager process list you can see it open and then close. This seems caused by GM:S (probably the updater) finding that the /Upgrade/ folder still exists, and doesn't know what to do with it anymore so it closes.

This can be fixed in a few ways:

- Manually move the contents of the /Upgrade/ folder to the /GameMaker-Studio/ folder.
- Delete the /GameMaker-Studio/Upgrade/ folder and relaunch (Note: This will download the update again).
- Uninstall/Reinstall GameMaker:Studio (this will install the latest version).

The reason i think its Kaspersky is i've found that the update will work fine if i temporally disable protection while installing it.


If you have anymore information you can add to this please post it. If you're having similar issues but caused by something other than Kaspersky, please also post.


EDIT:
Trace.log file size issue has been fixed in v1.0.303 (see: http://bugs.yoyogame...iew.php?id=5489)
  • 0

My recent tutorials: [Auto-Tiling] [Text Based Menu] [Sprite Based Menu] [View more at my site]
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
R.I.P Mom (1951-2008)


#2 xot

xot

    GMC Dismember

  • GMC Elder
  • 4785 posts
  • Version:GM:Studio

Posted 26 July 2012 - 08:04 PM

I've had this problem too and have also suspected anti-virus being the culprit. I am using ClamAV with Clam Sentinel. I've found uninstalling/reinstalling to be the only thing that works reliably for me.

I'm posting to add some information about where to download the current version of GameMaker:Studio.

Go here to view the GameMaker:Studio release notes:

http://store.yoyogam...tes-studio.html

Each version number headline is a link to download an installer for that version.

Uninstall your currently installed version of GameMaker:Studio.

Download and install the most recent version found at the top of the release notes.

Alternatively, the current release version of the GM:S installation package can always be downloaded from this link:

http://store.yoyogam...staller-1.0.exe

... or from this web page:

http://www.yoyogames...amemaker/studio
  • 0
GMLscripts.com, rise from your grave!

If any of my posts contain broken images or links, I can probably supply them for you. PM with a link to the post.

#3 Chronic

Chronic

    Administrator

  • Global Moderators
  • 2729 posts
  • Version:GM:Studio

Posted 26 July 2012 - 10:31 PM

GM:S will download the updates but always fails at installing them on my PC.

Are you using a virus scanner? (name?)
Did you try to disable it before updating?
Tried any of the suggestions above?
  • 0

My recent tutorials: [Auto-Tiling] [Text Based Menu] [Sprite Based Menu] [View more at my site]
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
R.I.P Mom (1951-2008)


#4 David Batty

David Batty

    GMC Member

  • GMC Member
  • 189 posts
  • Version:GM:Studio

Posted 28 July 2012 - 11:22 PM

This happened to me and I was without Studio for a few days because I got fed up of downloading the updates only to find that after installation nothing had changed, it was still the old studio version.

After a day of doing the above I found that double clicking on the studio icon on my desktop then failed to load anything, no error message, no activity, nothing.


In the end I uninstalled Studio and downloaded a fresh copy from the website, all installed ok and it works now.
  • 0

#5 ZingZingZap

ZingZingZap

    GMC Member

  • GMC Member
  • 110 posts
  • Version:GM:Studio

Posted 08 August 2012 - 07:33 AM

Similar story here.

Didn't realise it might be due to AV.

On updating my GM:Studio opens and closes several times a second, no way to stop other than restart my PC.
Upon restart, update hasn't been applied.

I've had to uninstall and then reinstall GM:Studio, which sometimes results in corrupt game files or game files that won't load.

This issue needs to be addressed.

Zzz
  • 0

signature.jpg


#6 fyatre

fyatre

    GMC Member

  • GMC Member
  • 27 posts
  • Version:GM:Studio

Posted 13 August 2012 - 05:48 PM

I'm using AVG and it also fails on copying so I just terminate the GMS process and move the files myself, delete the upgrade folder, and then everything is fine.


I use AVG and if I turn off the Resident Shield temporarily while installing/updating I don't get any issues.
  • 0

#7 vinicius

vinicius

    GMC Member

  • GMC Member
  • 234 posts
  • Version:GM:Studio

Posted 01 September 2012 - 07:45 PM

Same here, and Im using AVG. The only solution was reinstalling GMS. Its really annoyng and I already sent this issue to helpdesk and the answer was:

Hi Vinicius,

This generally happens when something in the background is running which GameMaker needs to use.

If you restart your computer then run the installer again the problem should go away.

If this does not fix the issue please let us know.

Thanks

Which doesn't worked...
  • 0
Posted Image

#8 @Alex@

@Alex@

    GMC Member

  • GMC Member
  • 4734 posts
  • Version:Unknown

Posted 07 September 2012 - 04:28 PM

I've had it constantly fail even with no anti-virus enabled. I'd just download the new installer but the file size is far to large to do that with every update. Any ideas on why it fails or solutions to fix just how bad this updater seems to be.
  • 0

2mma14z.jpg 2nu6efl.jpg 28whvdt.jpg


#9 Tennx

Tennx

    The Entrepreneur

  • GMC Member
  • 311 posts
  • Version:GM:Studio

Posted 07 September 2012 - 05:32 PM

Wait a few more hours and then try again.

http://gmc.yoyogames...dpost&p=4079493
  • 0
Getting in my way won't do anything good to you... unless you came to share your donuts.

#10 @Alex@

@Alex@

    GMC Member

  • GMC Member
  • 4734 posts
  • Version:Unknown

Posted 07 September 2012 - 06:00 PM

It's ridiculous how often it fails. Downloading the current installer at the speeds I get would take several hours.
  • 0

2mma14z.jpg 2nu6efl.jpg 28whvdt.jpg


#11 Tennx

Tennx

    The Entrepreneur

  • GMC Member
  • 311 posts
  • Version:GM:Studio

Posted 07 September 2012 - 06:10 PM

I know, I know, I tried it yesterday almost 6 times downloading the installer, and other 10 times just updating, so I know how do you feel. But patience is a virtue, my friend ;). I already informed this through Bug Tracker, so I should be fixed soon.
  • 0
Getting in my way won't do anything good to you... unless you came to share your donuts.

#12 @Alex@

@Alex@

    GMC Member

  • GMC Member
  • 4734 posts
  • Version:Unknown

Posted 07 September 2012 - 06:18 PM

It's just compounded by the quality of internet in the outskirts of Aberdeen , largest suburb in Europe and I'm getting around 20 KBPS. So evening trying to update takes upwards of half an hour.
  • 0

2mma14z.jpg 2nu6efl.jpg 28whvdt.jpg


#13 sandyd

sandyd

    Lord of the YoYo!!

  • GMC Elder
  • 141 posts
  • Version:Unknown

Posted 07 September 2012 - 08:11 PM

There will be a patch update option coming in the very near future.
  • 0
"Tao people never try, they do" Lao Tse

#14 Parnell_Games

Parnell_Games

    GMC Member

  • GMC Member
  • 74 posts
  • Version:GM:Studio

Posted 07 September 2012 - 09:26 PM

I can't even use the program now! I tried installing the updated version but it is now stuck on installing... 100%.

Why did you all release this program with all the stuff wrong with it? It's not a stable product by any means.:verymad: I'm thinking of getting a refund because I recently bought a standard license. GM8 wasn't this problematic even at 8.0!
  • 0
Favorite Quote:

... and if i was freaking out, EVERYTHING WOULD BE IN ALL CAPS...


#15 Tennx

Tennx

    The Entrepreneur

  • GMC Member
  • 311 posts
  • Version:GM:Studio

Posted 07 September 2012 - 10:19 PM

I can't even use the program now! I tried installing the updated version but it is now stuck on installing... 100%.

Why did you all release this program with all the stuff wrong with it? It's not a stable product by any means.:verymad: I'm thinking of getting a refund because I recently bought a standard license. GM8 wasn't this problematic even at 8.0!


You're free to do what you want with your money... but your lack of patience won't do anything good to anyone, specially to you Posted Image
  • 0
Getting in my way won't do anything good to you... unless you came to share your donuts.

#16 @Alex@

@Alex@

    GMC Member

  • GMC Member
  • 4734 posts
  • Version:Unknown

Posted 07 September 2012 - 10:32 PM

There will be a patch update option coming in the very near future.


This would be interesting if I could even download the installers or the updates. As it stands I have several installers that have terminated mid download and left me with installers of various sizes from 40Mb to 74Mb and don't seem to be resumable through either of methods I've tried to use so far. It's a real barrier to an otherwise great product.

Edit : Okay that's another 90MB file downloaded and its really just a waste of bandwidth even trying to update GameMaker.

Edited by @Alex@, 08 September 2012 - 12:46 AM.

  • 0

2mma14z.jpg 2nu6efl.jpg 28whvdt.jpg


#17 Loaf

Loaf

    Just loafing around

  • GMC:Member
  • 2164 posts
  • Version:GM:Studio

Posted 09 September 2012 - 12:06 PM

I got prompted for the GM:S update. Only anti-virus I have is Avast.

At first the update failed, it seemed to stop prematurely. So I reopened GM:S, re-downloaded it, and then it installed. I can use it fine, but I kept getting nagged to install the update even though Game Maker had updated successfully so I had click "skip this version" to be left alone lol.

:duck:


#18 Spyker

Spyker

    GMC Member

  • GMC Member
  • 793 posts
  • Version:GM:Studio

Posted 09 September 2012 - 09:16 PM

Mine will get stuck/non-responsive at the end of "installing" after downloading the update. I tried downloading the latest version directly from release notes and it worked, but after installing it tries updating again. No AVG's are enabled on my computer. Running on Windows 7
  • 0

Check out Night Bike for Android and iOS!

 

2j2wyvk.png

 

Curious on how to code in other languages? I highly recommend you check out Team Tree house. You'll learn a lot of skills and methods that will help with GameMaker, and you can learn how to code things to work with your game (websites, databases, etc). There are tons of small courses that range from beginner to advanced.


#19 David Batty

David Batty

    GMC Member

  • GMC Member
  • 189 posts
  • Version:GM:Studio

Posted 09 September 2012 - 10:19 PM

I upgraded to 1.1.412 when it came out, went away for the weekend, when I came back it still tells me I have 1.0 something and asks me to update. The update says it is downloading but finishes quickly and nothing happens.

When I look at the version I have it is 1.1.412 but the update software tells me I have 1.0 something.

This is the same problem I had last time the licencing system was changed.

My 1.1.412 is working ok so I will wait until this is fixed and another version of the software is out.
  • 1

#20 Spyker

Spyker

    GMC Member

  • GMC Member
  • 793 posts
  • Version:GM:Studio

Posted 09 September 2012 - 10:35 PM

Just thought I'd post that I went to where you download the free version of GM:S (http://www.yoyogames...amemaker/studio) and it will gave me the latest version. I have 1.1.416 now and since it's not trying to update, I'm assuming that's the newest.
  • 0

Check out Night Bike for Android and iOS!

 

2j2wyvk.png

 

Curious on how to code in other languages? I highly recommend you check out Team Tree house. You'll learn a lot of skills and methods that will help with GameMaker, and you can learn how to code things to work with your game (websites, databases, etc). There are tons of small courses that range from beginner to advanced.


#21 Parnell_Games

Parnell_Games

    GMC Member

  • GMC Member
  • 74 posts
  • Version:GM:Studio

Posted 10 September 2012 - 03:33 AM

I can't even use the program now! I tried installing the updated version but it is now stuck on installing... 100%.

Why did you all release this program with all the stuff wrong with it? It's not a stable product by any means.:verymad: I'm thinking of getting a refund because I recently bought a standard license. GM8 wasn't this problematic even at 8.0!


You're free to do what you want with your money... but your lack of patience won't do anything good to anyone, specially to you Posted Image


Lack of patience? I don't think so, I've been using GM since 4.2a was out. I'm just a little disappointing that over the years this product has lost it's stability. I know a lot has been added but I'm surprised were all having updating issues since updating was introduced in GM 8.1.

I got mine working, I just had to uninstall, do a system restore to before I installed it at all, and re-installed GM:S 1.1.
  • 0
Favorite Quote:

... and if i was freaking out, EVERYTHING WOULD BE IN ALL CAPS...


#22 Tennx

Tennx

    The Entrepreneur

  • GMC Member
  • 311 posts
  • Version:GM:Studio

Posted 10 September 2012 - 06:33 PM

I can't even use the program now! I tried installing the updated version but it is now stuck on installing... 100%.

Why did you all release this program with all the stuff wrong with it? It's not a stable product by any means.:verymad: I'm thinking of getting a refund because I recently bought a standard license. GM8 wasn't this problematic even at 8.0!


You're free to do what you want with your money... but your lack of patience won't do anything good to anyone, specially to you Posted Image


Lack of patience? I don't think so, I've been using GM since 4.2a was out. I'm just a little disappointing that over the years this product has lost it's stability. I know a lot has been added but I'm surprised were all having updating issues since updating was introduced in GM 8.1.

I got mine working, I just had to uninstall, do a system restore to before I installed it at all, and re-installed GM:S 1.1.


You only had to wait until 1.1.416 and that was all, :/ if you want a complete product then instead of complaining you could cooperate reporting bugs and suggestions to the bug tracker, as I do...

Asking for a refund is just an easy way to get the money back, but you would lose any right to ask for a better product because you wouldn't pay, legally. It's not bad though, but as I say, you would lose that right.

Edited by Tennx, 10 September 2012 - 06:34 PM.

  • 0
Getting in my way won't do anything good to you... unless you came to share your donuts.

#23 koala_knight

koala_knight

    GMC Member

  • New Member
  • 8 posts
  • Version:GM:Studio

Posted 15 September 2012 - 05:18 AM

I have been using the free version for the last week or so while I prepare to get the complete package for my start-up company. Today was the first time I was asked to update and I seem to be having a similar issue to everyone here. I'm running Win7. I have no anti-virus even installed on my system at all. (so that rules out an AV issue.) And I'm having the updater hang at 100% and become unresponsive if I click on it. And the program opens in the background, but never appears on screen indicating that it is crashing during initialization. Uninstalling and reinstalling has proven useless.

EDIT: Restarted, uninstalled, reinstalled from newest installer, and nothing has changed.

Edited by koala_knight, 15 September 2012 - 05:32 AM.

  • 0

#24 GameRoom

GameRoom

    GMC Member

  • GMC Member
  • 781 posts
  • Version:GM:Studio

Posted 16 September 2012 - 05:35 PM

I tried copying the contents of upgrade.zip to the upgrade folder and everything is password protected. Reinstalling doesn't help either.

EDIT: Eventually, I got version 1.0.342 installed, but something must have gone wrong. When I try to run the game it shows an error box of an error that isn't there. I can't work on my game at all until this is fixed.

Posted Image

Edited by GameRoom, 18 September 2012 - 01:13 AM.

  • 0

infestation.png


#25 Erik Leppen

Erik Leppen

    GMC Member

  • GMC Member
  • 2751 posts
  • Version:GM:Studio

Posted 18 September 2012 - 02:48 PM

Anyone else who can't upgrade to 1.1.450? I have 1.1.416, it notices the update, it downloads it and then nothing. Normally the "waiting for GM to close" appears, but it doesn't. I can just open my project and work on it. Given all upgrade problems, I'm reluctant to deinstalling everything, because right now I at least have 1.1.416.
  • 0

promo_briquidmini_500x150.png


#26 Oracizan

Oracizan

    Mutant Dreamer

  • GMC Member
  • 550 posts
  • Version:GM:Studio

Posted 20 September 2012 - 04:29 PM

Mine didn't seem to know there was an update. I only realized that there should be one when I submitted a bug report and Russel said it should already be fixed.

I tried updating to that version with no success. The updater freezes right before finishing the 'install' step, so I'm stuck uninstalling & reinstalling.
  • 0

#27 Neonlare

Neonlare

    GMC Member

  • GMC Member
  • 56 posts

Posted 20 September 2012 - 09:29 PM

Uninstalled Game Maker, installed it again from the link provided, but after it goes through Installing the .exe never runs. Doesn't work, at all, it just won't boot up to anything. No Editor, no Project Organizer, nothing. Sure hope this gets solved soon, want to get some more progress on my projects! D:
  • 0

#28 rwkay

rwkay

    YoYo Games CTO

  • YoYo Games Staff
  • 2937 posts
  • Version:Unknown

Posted 21 September 2012 - 08:21 AM

If you are having problems with the Updater this issue is most likely zombie 5piceIDE.exe processes so...

0) Exit GameMaker:Studio
1) Uninstall GameMaker:Studio
2) Start Task Manager and kill any 5piceIDE.exe processes that are hanging around
3) Ensure that %appdata%\GameMaker-Studio is completely empty and has no files left in it at all
4) Install from the stand alone installer...

The zombie process issue should be fixed in 1.1.450 but we will not see the benefit of that until everyone upgrades from it.

Russell
  • 0

#29 Neonlare

Neonlare

    GMC Member

  • GMC Member
  • 56 posts

Posted 21 September 2012 - 09:53 AM

Tried reinstalling again, no use unfortunately. No 5PICE.exe processes are hovering about and I don't seem to have any appdata on game maker studio at all on my drive. Is there a direct link to the latest version? The 1.0 link downloads, but doesn't seem to go anywhere after nstalling. On windows 7 if that helps at all.
  • 0

#30 rwkay

rwkay

    YoYo Games CTO

  • YoYo Games Staff
  • 2937 posts
  • Version:Unknown

Posted 21 September 2012 - 10:02 AM

The installer can be downloaded from http://www.yoyogames...oad/studio/free - It is the same link as the GMStudio Free version (content is the same only the license changes).

Russell
  • 0

#31 Neonlare

Neonlare

    GMC Member

  • GMC Member
  • 56 posts

Posted 21 September 2012 - 10:17 AM

Managed to find out what was going on, as the installers kept failing. There was some files that weren't being uninstalled properly in the appdata file, but wouldn't show up when searched for, had to find them manually and remove them. They were in Local rather than Roaming, so anyone else having similar issues might want to check that portion of the appdata file out as well. For me it was in my Owner's file as a hidden file.
  • 0

#32 michael pw

michael pw

    GMC Member

  • GMC Member
  • 1488 posts
  • Version:GM8.1

Posted 01 October 2012 - 10:35 PM

I recently changed form 1.0 to 1.1 and when it asked me to install, i kept on just clicking next, on install directory it was on the old one for studio:
Users/Michael/GameMakerStudio 1.0

And it just kept on stopping at 100% (on the update part) and it froze after that. (This was with all anti-virus disabled).
I Then changed the save directory to a new one (which i named GameMakerStudio 1.1) and that worked fine when i did that. I Think deleting the old GameMakerStudio 1.0 folder might work too.
  • 1

Known as MishMash on the internet, If only my username could be changed :D?

Posted Image

Working on Sharp Edge, a 3D Level designer which exports to GMMOD and textures, with a vast toolset, and fancy GUI. ( So far, software is only going to be distributed with my game, in the future, it will be up for public use and with the ability to customise the software using the Plugin System to suite your games needs.)
Also working on 3D Multiplayer FPS Global Anarchy Denied Operations.


#33 David Batty

David Batty

    GMC Member

  • GMC Member
  • 189 posts
  • Version:GM:Studio

Posted 09 October 2012 - 11:13 PM

I was told there was a studio update today, I downloaded it three times and then ... nothing ... that happened each time.

If I run studio and choose the option to ignore the update then when studio does run its still the old version running, it was not updated during the three tries.

Does it look like I have to uninstall studio again (I had to do that last time) then do a new install ?

I always dislike uninstalling because I have to wait to see that all my android etc. settings are still there ! They always are but ... you never know !

Edited by David Batty, 09 October 2012 - 11:15 PM.

  • 0

#34 Akrid

Akrid

    GMC Member

  • GMC Member
  • 113 posts

Posted 10 October 2012 - 03:46 AM

v1.1.522 won't install for me. Downloads and then doesn't do anything. All previous updates worked fine for me.
  • 0

#35 Parnell_Games

Parnell_Games

    GMC Member

  • GMC Member
  • 74 posts
  • Version:GM:Studio

Posted 10 October 2012 - 04:50 AM

v1.1.522 won't install for me. Downloads and then doesn't do anything. All previous updates worked fine for me.


I'm in the same boat here.
I've tried the updater it does a file check... then download... then nothing.
I've tried downloading the update manually from the page that is shown in the updater and it errors out when I run the exe.

It says the media is broken and I should contact the publisher. This first happened 6 hours ago, when is the update going to be replaced with a working one?
  • 0
Favorite Quote:

... and if i was freaking out, EVERYTHING WOULD BE IN ALL CAPS...


#36 ObsidianNovels

ObsidianNovels

    GMC Member

  • GMC Member
  • 717 posts
  • Version:GM:HTML5

Posted 10 October 2012 - 07:06 AM

v1.1.522 won't install for me. Downloads and then doesn't do anything. All previous updates worked fine for me.


Same issue here. It seems like download "breaks." It starts out all right, then, before loading bar has reached even half, it's suddenly 100%.
  • 0

#37 mms

mms

    GMC Member

  • GMC Member
  • 30 posts
  • Version:GM:Studio

Posted 10 October 2012 - 04:31 PM

I was told there was a studio update today, I downloaded it three times and then ... nothing ... that happened each time.

If I run studio and choose the option to ignore the update then when studio does run its still the old version running, it was not updated during the three tries.

Does it look like I have to uninstall studio again (I had to do that last time) then do a new install ?

I always dislike uninstalling because I have to wait to see that all my android etc. settings are still there ! They always are but ... you never know !


i have the same problem: click install and restart but nothing happens....it does not close gms too it is still open (the old version)..win 7 64 bit
  • 0

Virtual Mobile Games
current project with gm:

My link

 

650x150.jpg


#38 TeamSteeve

TeamSteeve

    GMC Member

  • GMC Member
  • 1359 posts
  • Version:GM:Studio

Posted 10 October 2012 - 10:29 PM

Same problem here.

EDIT: Used my old installer to re-install (I didn't uninstall) and then it updated fine.

Edited by TeamSteeve, 10 October 2012 - 10:54 PM.

  • 1

TeamSteeveBanner.png


#39 blackbeard

blackbeard

    GMC Member

  • GMC Member
  • 64 posts
  • Version:GM:Studio

Posted 11 October 2012 - 02:14 AM

I had the same problem happen; however, it also wiped out several resources such as sprites and fonts. I've had to back them up from an older version of the same project... still not updated though.
  • 0

#40 Lordfef

Lordfef

    GMC Member

  • GMC Member
  • 177 posts
  • Version:GM:Studio

Posted 11 October 2012 - 08:58 AM

Same problem here.

EDIT: Used my old installer to re-install (I didn't uninstall) and then it updated fine.



Hi i have the same problem.
I download new version, until i have the button: install and Relaunch. I press the button but nothing appen...
I try 5 time but nothing

How do you use old installer? What step do you do to do this?

Thank's
  • 0

#41 TeamSteeve

TeamSteeve

    GMC Member

  • GMC Member
  • 1359 posts
  • Version:GM:Studio

Posted 11 October 2012 - 09:58 AM

I had the original installer that I used to install GM:S. All I did was run that one. If you don't already have an old one then I don't think I can help.
  • 0

TeamSteeveBanner.png


#42 Lordfef

Lordfef

    GMC Member

  • GMC Member
  • 177 posts
  • Version:GM:Studio

Posted 11 October 2012 - 10:18 AM

I had the original installer that I used to install GM:S. All I did was run that one. If you don't already have an old one then I don't think I can help.


I find in my download folder the file GMStudio-Installer-1.0.exe that i used the first time i download and install GM:S . You mean to re-launch it?
  • 0

#43 TeamSteeve

TeamSteeve

    GMC Member

  • GMC Member
  • 1359 posts
  • Version:GM:Studio

Posted 11 October 2012 - 10:21 AM

Yep. Then let it update itself as it usually would after it re-installs.
  • 0

TeamSteeveBanner.png


#44 Lordfef

Lordfef

    GMC Member

  • GMC Member
  • 177 posts
  • Version:GM:Studio

Posted 11 October 2012 - 04:34 PM

Yep. Then let it update itself as it usually would after it re-installs.


all the Global setting of actual version will remain or there is the risk to lose all setting?
Thank's
  • 0

#45 TeamSteeve

TeamSteeve

    GMC Member

  • GMC Member
  • 1359 posts
  • Version:GM:Studio

Posted 11 October 2012 - 09:15 PM

I didn't lose any settings or recent files or anything of the sort.
  • 0

TeamSteeveBanner.png


#46 Lordfef

Lordfef

    GMC Member

  • GMC Member
  • 177 posts
  • Version:GM:Studio

Posted 11 October 2012 - 11:36 PM

I try to run my first downloaded file (GMStudio-Installer-1.0.exe), i must re-insert my license and now it' updated to the last release and i have all my old setting.

Thank you very much for your help!
  • 0

#47 davilillo

davilillo

    GMC Member

  • GMC Member
  • 26 posts
  • Version:GM:Studio

Posted 12 October 2012 - 08:11 PM

Since this last update i am not able to run the runner on my iphone, i even tried to reinstall the new "updated runner" but still doesnt work, after the runner ends the download it closes itself, its happening to someone else?
  • 0

#48 davilillo

davilillo

    GMC Member

  • GMC Member
  • 26 posts
  • Version:GM:Studio

Posted 12 October 2012 - 08:55 PM

Since this last update i am not able to run the runner on my iphone, i even tried to reinstall the new "updated runner" but still doesnt work, after the runner ends the download it closes itself, its happening to someone else?


Ok solved!
In case someone is having problems with this, check GameMaker:Studio_for_iOS like the first time you install it and BE SURE to follow all steps!

Edited by davilillo, 12 October 2012 - 08:56 PM.

  • 0

#49 MaxTerminus

MaxTerminus

    GMC Member

  • GMC Member
  • 6 posts
  • Version:Unknown

Posted 22 October 2012 - 02:29 AM

Yes, most of the recent updates go into an update loop, including the most recent update. Rarely, restarting the computer and then starting Gamemaker Studio shows that the update installed, but most of the time, I must uninstall, download and re-install. Not sure what firewalls or virus scanners have to do with it. Many other software updates install fine, and until recently Gamemaker Studio updates installed without issue.
  • 0

#50 chance

chance

    GMC Member

  • Global Moderators
  • 8762 posts
  • Version:GM:Studio

Posted 25 October 2012 - 11:06 AM

Yes, most of the recent updates go into an update loop, including the most recent update.

Yes, mine just started doing this too. I haven't been able to update since 1.1.513

But I just noticed (yeah... I'm a bit late) the dev log says "Updater has been modified to give more information and pave the way for Delta Updates - NOTE: you need to install from the standalone installer to get all this goodness"

So I plan to do that later today. Either way, perhaps Mike/Russell can clarify what's needed here.

Edited by chance, 25 October 2012 - 11:07 AM.

  • 0