Jump to content


Photo

GMS: Sound on android


  • Please log in to reply
7 replies to this topic

#1 SyCx1

SyCx1

    GMC Member

  • GMC Member
  • 31 posts
  • Version:GM:Studio

Posted 03 March 2012 - 09:28 PM

Hey guys! So this is my first GMS post. I got an invite email and have been using GMS to work on a game that I've been making for awhile(which I'm hoping I don't regret because I can't export stand-alones in GMS at the moment and GM:HTML5 doesn't open my project up now that I've worked on it in GMS...).

Anyways-When I run my game in html5 or the c++ runner everything is fine and you can hear the sound and all very well but when I run the game on my Android phone the game runs great and all but you can't hear any of the sounds or music.

I didn't want to report this as a bug until I figure out more about why I can't hear anything.

I'm using an LG Optimus V. Had to update adb manually on the phone before the yyg runner install would take but it was worth the trouble.

The game I'm working on is an RTS and it's starting to look a bit polished :o)

Anyone got any suggestions as to why the sound doesn't work?

Edited by SyCx1, 03 March 2012 - 09:29 PM.

  • 0

#2 Nocturne

Nocturne

    Nocturne Games

  • Administrators
  • 21727 posts
  • Version:GM:Studio

Posted 03 March 2012 - 09:31 PM

Donīt feel bad about posting a bug, as even if itīs a simple mistake you are making, it helps us to know what things we still need to explain... And if itīs a bug, then you are also helping as then we can fix it!
  • 0

#3 SyCx1

SyCx1

    GMC Member

  • GMC Member
  • 31 posts
  • Version:GM:Studio

Posted 03 March 2012 - 09:39 PM

Donīt feel bad about posting a bug, as even if itīs a simple mistake you are making, it helps us to know what things we still need to explain... And if itīs a bug, then you are also helping as then we can fix it!


ok cool i'll initiate some dialogue over on the bug tracker then. but should i still try to post on this forum too? cuz i have a feeling i am just missing something simple.
  • 0

#4 Nocturne

Nocturne

    Nocturne Games

  • Administrators
  • 21727 posts
  • Version:GM:Studio

Posted 03 March 2012 - 09:39 PM

Of course! The bug tracker and the forums are complimentary and the guys at YoYo pay attention to both...
  • 0

#5 Robert3DG+

Robert3DG+

    Designer

  • GMC Member
  • 1925 posts
  • Version:GM:Studio

Posted 03 March 2012 - 11:37 PM

Does sound work at all with GMS? I've been messing with the C++ Runner and haven't heard a thing yet.
  • 0

#6 scurvycapn

scurvycapn

    GMC Member

  • GMC Member
  • 187 posts
  • Version:GM:Studio

Posted 04 March 2012 - 03:19 AM

While mp3s are not playing in Android currently, I've had no issues with wav files playing on my phones or tablet.
  • 0

#7 rwkay

rwkay

    YoYo Games CTO

  • YoYo Games Staff
  • 2314 posts
  • Version:Unknown

Posted 04 March 2012 - 05:23 AM

On Windows if you install OpenAL then it will work... we are working to resolve problems with the runner / installer combo on windows devices - http://connect.creat...ads/oalinst.zip is the link for download.

MP3s on Android and iOS are not working just now, though WAV playback will work, we will fix the MP3 playback when I get back from GDC.

Russell
  • 0

#8 Robert3DG+

Robert3DG+

    Designer

  • GMC Member
  • 1925 posts
  • Version:GM:Studio

Posted 04 March 2012 - 03:45 PM

Thanks rwkay, installing OpenAL worked for me (Getting sound to play with the Windows C++ Runner). In the future how will OpenAL installation work for people who don't have it? Or is that something that can just be packed in the executable?
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users