Jump to content


Photo

after update new version,the js cript dont encryp


  • Please log in to reply
7 replies to this topic

#1 azcodon

azcodon

    GMC Member

  • GMC Member
  • 193 posts
  • Version:Unknown

Posted 02 March 2012 - 03:55 AM

when you compile html5 ,gmhtml5 auto encryp the js file.After my update it dont encryp the file.js which User define
and i feel the game make by GM4html5 dont secure
what problem?

Edited by azcodon, 05 March 2012 - 07:56 AM.

  • 0

#2 azcodon

azcodon

    GMC Member

  • GMC Member
  • 193 posts
  • Version:Unknown

Posted 05 March 2012 - 07:58 AM

no ideas?
  • 0

#3 Nocturne

Nocturne

    Nocturne Games

  • Administrators
  • 20908 posts
  • Version:GM:Studio

Posted 05 March 2012 - 08:11 AM

What version of GM:Html5 are you on? Open Help >>> About GameMaker to find out.... And make sure you are looking at the COMPILED output (ie: The one made with the "Create Executable" option) as the temp output for testing is not obfuscated. With the current version (1.0.216) it works fine for me.
  • 0

#4 azcodon

azcodon

    GMC Member

  • GMC Member
  • 193 posts
  • Version:Unknown

Posted 05 March 2012 - 09:01 AM

What version of GM:Html5 are you on? Open Help >>> About GameMaker to find out.... And make sure you are looking at the COMPILED output (ie: The one made with the "Create Executable" option) as the temp output for testing is not obfuscated. With the current version (1.0.216) it works fine for me.


i use lastest version 1.0.216.i think you fail.you let delete all your script then use Gm4html5 excute again,you will see
  • 0

#5 Nocturne

Nocturne

    Nocturne Games

  • Administrators
  • 20908 posts
  • Version:GM:Studio

Posted 05 March 2012 - 10:20 AM

Sorry, we are unable to replicate this... Could you please explain EXACTLY what you are doing to get this result? Every test I do compiles an obfuscated JS file. Also, post a screenshot of the code (or the actual JS file itself if you don't mind)...

PS: Telling me "I fail" just because I don't happen to get the same results as you will not make me want to fix your problem...Posted Image
  • 0

#6 azcodon

azcodon

    GMC Member

  • GMC Member
  • 193 posts
  • Version:Unknown

Posted 05 March 2012 - 03:18 PM

i know your trouble but i must say that is as update as bug
  • 0

#7 Nocturne

Nocturne

    Nocturne Games

  • Administrators
  • 20908 posts
  • Version:GM:Studio

Posted 05 March 2012 - 03:23 PM

You make absolutely no sense whatsoever... Posted Image. If you are sure it's a bug, then file a bug report. If you want me to help you then please explain further (as I have already asked!).
  • 0

#8 azcodon

azcodon

    GMC Member

  • GMC Member
  • 193 posts
  • Version:Unknown

Posted 06 March 2012 - 03:07 AM

You make absolutely no sense whatsoever... Posted Image. If you are sure it's a bug, then file a bug report. If you want me to help you then please explain further (as I have already asked!).


i mean the script which i define(not gm).i add a script to extension then excute.it not encryp
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users