Jump to content


Photo

Gmwindows


  • This topic is locked This topic is locked
22 replies to this topic

#1 Giles1991

Giles1991

    GMC Member

  • New Member
  • 216 posts

Posted 26 March 2005 - 03:23 PM

ok well i havent 100% tested this BUT i have tested some of the functions

KNOWN BUGS:
  • the GMW_GetText Function returns some jibberish
Download Link: HERE
the zip contains a example showing some of the controls you can use

Edited by KC LC, 05 October 2007 - 12:38 PM.

  • 0

#2 lewa

lewa

    GMC Member

  • New Member
  • 587 posts

Posted 26 March 2005 - 06:33 PM

You still got some script bugs.
I couldent even run it, so I fixed the bug, and got another bug from a different script.
  • 0

Supercilious, I know. Sorry. I blame GIMP.

#3 Giles1991

Giles1991

    GMC Member

  • New Member
  • 216 posts

Posted 26 March 2005 - 07:16 PM

You still got some script bugs.
I couldent even run it, so I fixed the bug, and got another bug from a different script.

<{POST_SNAPBACK}>

whitch script? and what verson of GM do you have i scripted it in GM6 and what does this bug do? i need more info inorder to help ^_^

Edited by Giles1991, 26 March 2005 - 07:17 PM.

  • 0

#4 david24

david24

    Owner of GrayDragon.net

  • New Member
  • 165 posts

Posted 26 March 2005 - 11:48 PM

It's an external call error... and actually... this looks exactly like GMWidgets... did you just copy it and rename some scripts?

And actually, if you DID make, don't you think you would have tested every script first?

^_^
  • 0

#5 Giles1991

Giles1991

    GMC Member

  • New Member
  • 216 posts

Posted 27 March 2005 - 01:01 AM

It's an external call error... and actually... this looks exactly like GMWidgets... did you just copy it and rename some scripts?

And actually, if you DID make, don't you think you would have tested every script first?

^_^

<{POST_SNAPBACK}>

i did make this on my ownjust look and compair mine has functions that GMW doesant and i dident get a chance to test it ALL just a lil sry

ok fixed the errors redownload samelink :D

Edited by Giles1991, 27 March 2005 - 01:09 AM.

  • 0

#6 AlternateVirus

AlternateVirus

    GMC Member

  • New Member
  • 118 posts

Posted 27 March 2005 - 04:19 PM

did u even try the gm6 it doesn't load?
one of the scripts is missing a ")" i think

Edited by AlternateVirus, 27 March 2005 - 04:20 PM.

  • 0

#7 Giles1991

Giles1991

    GMC Member

  • New Member
  • 216 posts

Posted 27 March 2005 - 04:36 PM

did u even try the gm6 it doesn't load?
one of the scripts is missing a ")" i think

<{POST_SNAPBACK}>

oops sry i think it's fixed now
  • 0

#8 lelo707

lelo707

    GMC Member

  • New Member
  • 258 posts

Posted 27 March 2005 - 04:57 PM

I suggest you change the name of this DLL, otherwise there will be confusion between this and GWindows (a.k.a GMWindows)
  • 0

#9 Giles1991

Giles1991

    GMC Member

  • New Member
  • 216 posts

Posted 27 March 2005 - 10:54 PM

I suggest you change the name of this DLL, otherwise there will be confusion between this and GWindows (a.k.a GMWindows)

<{POST_SNAPBACK}>

oh when i named it i dident kno that GWindows is also named GMWindows i'll think of a new name...
  • 0

#10 Killamancer

Killamancer

    GMC Member

  • GMC Member
  • 116 posts

Posted 10 April 2005 - 02:44 PM

I am using gm5 with this and cant get GMW_BT_GetState or whatever its called to work. I did if GMW_BT_Getstate == true { //code } but nothing hapens when i click the button. and i used the right button id.
  • 0

#11 ai guy

ai guy

    GMC Member

  • New Member
  • 64 posts

Posted 10 April 2005 - 08:43 PM

uh, it still doesn't work, even though you've 'fixed' it.
  • 0

#12 THE GAME

THE GAME

    GMC Member

  • New Member
  • 98 posts

Posted 01 August 2005 - 10:03 PM

[SIZE=14][COLOR=red]the ling is broking!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!![COLOR=red][SIZE=14] :D
  • 0

#13 Smarttart62

Smarttart62

    designFUSION™

  • New Member
  • 2619 posts

Posted 01 August 2005 - 11:35 PM

Apr 10 2005
Figures its broken... Why do you people bump these old topics...
You should know that by now :D
-Steve
  • 0

#14 Giles1991

Giles1991

    GMC Member

  • New Member
  • 216 posts

Posted 02 August 2005 - 01:18 PM

well if the post wasent bumped i couldent have fixed the link all things i hosted's links will be busted no-ip.com droped my account so i bought my own domain :)
  • 0

#15 THE GAME

THE GAME

    GMC Member

  • New Member
  • 98 posts

Posted 02 August 2005 - 03:18 PM

dow jou heve a dll whit only win_32 buttons that works whit GM :)
  • 0

#16 Smarttart62

Smarttart62

    designFUSION™

  • New Member
  • 2619 posts

Posted 02 August 2005 - 03:34 PM

Well still, you could have pm'd the author :)
-Steve
  • 0

#17 Giles1991

Giles1991

    GMC Member

  • New Member
  • 216 posts

Posted 03 August 2005 - 04:43 PM

good news....... i will be getting to work n this program again this time i have alot more experiance with windows so i can mostlikly make it better.
  • 0

#18 joepie91

joepie91

    GMC Member

  • GMC Member
  • 203 posts

Posted 15 October 2005 - 09:44 PM

erm.... i can't even call this 'coded'.... i fixed first bug (the missing ")") and it came up with another one (couldn't call external function or something) and i couldn't fix - i CAN fix most bugs myself, so this is awfully coded - and when using the scripts version there a resource data error.... PLEASE make a working version before you publish it and TEST it!
  • 0

#19 UndergroundMark

UndergroundMark

    GMC Member

  • New Member
  • 219 posts

Posted 15 October 2005 - 10:13 PM

if you cant call external function that means that the dll that it is trying to read from isnt in the same folder as the game or the specified folder in the script
  • 0

#20 gml_josea

gml_josea

    Killing Noobs

  • New Member
  • 466 posts

Posted 16 October 2005 - 01:30 AM

well, resolve all the bugs before releasing something ;) is really annoying o try something,and when you run it tons of compilation errors.
  • 0

#21 gamemaker intermediate

gamemaker intermediate

    GMC Member

  • New Member
  • 123 posts

Posted 03 May 2006 - 01:10 AM

bump


i found the loading bug im not sure why

global._createipbox=external_define(dll,"GMW_CreateIpAddress",ct,ty_real,0)

if you remove this the dll loads and almost everything runs ok but as soon as u try using it to add things it jams up

Edited by gamemaker intermediate, 03 May 2006 - 01:10 AM.

  • 0

#22 ChIkEn AtE mY dOnUtS

ChIkEn AtE mY dOnUtS

    Pwner of barcodes

  • GMC Member
  • 2410 posts

Posted 03 May 2006 - 01:13 AM

[quote name='gamemaker intermediate' date='May 2 2006, 07:59 PM']
bump


i found the loading bug im not sure why

global._createipbox=external_define(dll,"GMW_CreateIpAddress",ct,ty_real,0)

if you remove this the dll loads and almost everything runs ok but as soon as u try using it to add things it jams up

<{POST_SNAPBACK}>

bumped... again???
you should know better (like smarttart said ::lmao::)
  • 0
I've moved away from GM. If you want to contact me, feel free to email ryanwebdev@gmail.com.

Thanks,
Ryan.

#23 pcnerd

pcnerd

    GMC Member

  • New Member
  • 197 posts

Posted 18 January 2007 - 12:22 AM

All the scripts work fine for me if you export the scripts first and import it into annother game... dunno why. Could somebody help with the "GMW_CreateWindow" function? does it return a new window handle? Otherwise, how do you add anything to it?

Also, the TabControll functions...

Edited by pcnerd, 19 January 2007 - 12:04 AM.

  • 0